PDA

View Full Version : Driveshaft Clang with FMS Aluminum Driveshaft



Chuck
04-09-2017, 11:18 PM
I have previously written quite a chapter here about a thread I started many years ago. Uploading pictures crashed both SVOCA and my computer so this time I'll just say:

Installed rebuilt 8.8 in place of old 7.5" rear-end. Now drives whisper quiet with no clang at all. Perfect setup on new Yukon 4.11 gears with carbon clutch posi.

45479 45480 45481 45482

I also have a pretty nice way of removing undercoating without heat or putty knives.

SVOeric
04-10-2017, 01:24 AM
Looking good Chuck

Fox1
04-10-2017, 01:20 PM
nice!

svono50
04-10-2017, 01:54 PM
Looks good and I bet you are enjoying the new gear ratio!

Chuck
04-11-2017, 01:33 PM
The 4.11 ratio works real well with the Boport 1.9 cam! With the old A237 cam, performance went home at about 5K RPM. The Boport makes more power the higher the revs get (starting at about 3K). One of the biggest gains made here is finally removing the sprayed on undercoating that nailed the Konis. Been bugging me for 31 years. I used Under-Gone from Eastwood and it worked pretty well after many, many applications of the foam. When I was done, my old metal pan had quite a bit of undercoating residue and the toothbrush was clean but the bristles were black. Since then I went to Home Depot and bought some of the ZEP orange-based heavy duty degreaser. I sprayed some in that old metal pan and the junk dissolved. Even the bristles of the toothbrush returned to white. One pass with the hose and the pan is cleaner than it has been in 15 years! ZEP makes amazing products!