Results 1 to 7 of 7

Thread: My Pimp Build

  
  1. #1
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E

    My Pimp Build

    ALL PICS here can be enlarged by clicking on them

    Starting a thread here to document the install of my PIMP, on my basically stock SVO.
    This is the black 85.5 at the reunion last year, which was running TWEECER, and MASS air-flow, and 60# injectors. anyone wants that TWEECER, let me know.

    Received the box today, here's the parts.
    Click image for larger version. 

Name:	IMG_20180324_194624.jpg 
Views:	20 
Size:	246.4 KB 
ID:	45921
    one PimpXS
    one Spartan 2 wideband controller
    one Air Fuel gauge
    one boost controller
    lots of assorted wiring and docs.

    Day 1 ---
    I'm not actually going into the garage today, so I just have some basic configuration to do on the PIMP. Reading through the docs, first thing I need to do is set some base configuration jumpers.

    Jumpers sound like a complicated thing, but same type of thing you'd see on back of a hard-drive, or motherboard. Here's the config so far.

    I'm running 60# Siemens DEKA high imp injectors, still in batch fire (for now) -- JP1 and JP14 on

    Plug and play copnfiguration (with TFI), yep, JP2 on

    TFI, yep, jp19 -- on 2-3

    Fan control, I plan to run dual fans = JP3, jp7 on (JP3=pin 55, jp7 =pin 52), so fan 1 can kick on at 195, fan 2 at 210.
    NOTE: there is a JP3 on the darker colored communication board inside the pimp. The instructions say, all jumpers on GREEN board. Dont put jumpers on the board that has the USB connector on it.

    Table switching -- yep, need that (so my wife can drive) jp11 -- hooks to the existing prem/unleaded switch.

    Boost controller -- yep, need that, JP9 -- should note, this won't work with the stock controller,
    Their boost controller is an actual ford part, I suspect the one the ecoboost uses.

    No VSS yet.. so jp15-17 are off.


    Click image for larger version. 

Name:	IMG_20180324_183057.jpg 
Views:	18 
Size:	259.5 KB 
ID:	45922

    That's about all I'm going to do today.
    Next up is running to the muffler shop, to get an O2 bung welded into my downpipe for the Wideband.
    Then some wiring for the wideband.

    As this car is already wired for a LA3 computer already has an ACT wired to pin 25.
    95% of the wiring is already set. The only wiring needed will be unplugging the MAF, and chopping the original O2 sensor wire for connection to the wide-band, and the rest of the wide-band wiring.
    As the wide-band is a heated type of sensor, it needs voltage, where the stock O2 sensor did not.

    The wideband sensor also recommends it's only powered when the engine is running, I need to look into where the best place to get power from.

    Feel free to ask any questions, or point out anything I might have missed. There are a few 'reserved' posts after this one, so people reading later can read in order, instead of scrolling through lots of posts.
    Eric C
    SVOCA Webmaster

  2. #2
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    So someone asked to give a bit more info on the jumpers. I've already sealed up the PIMP, but, I had an old sound card sitting here that I can show how they work.

    A jumper is simply a little black 'thing' that connects 2 pins on board.
    This is a Jumper.
    Click image for larger version. 

Name:	jumper4.jpg 
Views:	5 
Size:	260.7 KB 
ID:	45926

    Here is a board with some pins on it. You can tell which jumper you're looking at by the label (circled here)
    Click image for larger version. 

Name:	jumper1.jpg 
Views:	9 
Size:	229.2 KB 
ID:	45925

    The board will have something to identify where pin1 is.
    Click image for larger version. 

Name:	jumper2.jpg 
Views:	7 
Size:	228.9 KB 
ID:	45924
    This is one LARGE group of jumpers, you won't typically find something like this on your PIMP. A set like this on the PIMP would have a label above it, that said J2 - J14. but what's shown here is one large group of pins.

    If the instructions said, jump J2, I would install the jumper like this. If it said jump J3, you would jump the next 2 down
    Click image for larger version. 

Name:	jumper3.jpg 
Views:	6 
Size:	201.9 KB 
ID:	45923


    Looking at jumper J6, it's labeled screwy on this board, but assuming the far left pin was 1,
    If the instructions said, jump J6. pins 2-3, I would install it like this.
    Click image for larger version. 

Name:	jumber 5.jpg 
Views:	10 
Size:	229.9 KB 
ID:	45927

    Full PIMP jumper map, (PIMPXS, yours may differ)
    Click image for larger version. 

Name:	PIMP-jumpers.jpg 
Views:	13 
Size:	250.9 KB 
ID:	45929
    Eric C
    SVOCA Webmaster

  3. #3
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    -- Day 2

    not a lot of progress or 'imagery' today -- Went out after work to get this wide-band installed.
    Click image for larger version. 

Name:	wb.jpg 
Views:	5 
Size:	11.5 KB 
ID:	45930


    I got good news, I pulled the car up on ramps, to mark the location for the wide band sensor, and it already had a sensor!! I traced the wire down, and it was just cut right behind the clock / center console. no trip to the muffler shop for welding required!
    Since I have a new sensor already, I'll go ahead and replace it, but keep the extra for a spare.

    An image above of the wide-band I purchased, a Spartan II. You see the 'big' end to the left, that's where the wide-band sensor plugs in. The remaining wiring, consists of
    1 red power,
    2 grounds (white and black) Black goes to ECU ground, white goes to something more substantial.
    1 green wire, which feeds the PIMP
    1 brown wire, emulates a narrow-band, not needed for me
    1 blue wire, which is a 'heat-up' light

    With the wide-band sensor installed, I ran the wire up through the shifter hole, I ZIP-tied the unit shown above to the metal that the relays are connected to behind premium switch, so it won't rattle. Ran the rest of the wires behind the glovebox, into the ECU area, where I picked up power (From the power windows), 2 separate grounds, and the green wire, that runs to pin 29 into the computer, as well as my fancy gauge, which I've not hooked up just yet.

    At this point, I did go ahead and connect the PIMP. Connected to it with Tuner studio, calibrated the TPS, and AFR (Wide-band).

    Next steps were to crank, with the injector harness disconnected to verify RPM is seen in Tuner studio. I wasn't seeing RPM on cranking, but, dinner was ready, and I was about done for the day.

    Will look into it next time I have a chance to work on it.
    Eric C
    SVOCA Webmaster

  4. #4
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    -- Day 3
    Not a lot of time to work on stuff tonight, had to attend the wife's birthday dinner. I did get some time to play tho.

    Had about 30 mins to look at the no spark issue-- I had posted on stingers forum, and they immediately said, check JP2, well I thought I had jumped JP2, but guess what, I MISSED IT. Guess that goes back to Bruce's comment about following directions...

    So I've got spark now, and not enough time to follow the rest of the directions to start it



    so AFTER dinner---
    I had not yet connected my fancy Air/Fuel gauge to my wide-band. It was connected to my PIMP, but no gauge, and hadn't even considered a place to mount it.

    A few months back, I had run across a broken clock/3-switch console panel, and had picked it up for a few bucks. It's an 84 panel, and I had mainly picked it up for the 3 switches that were in it. Today, I remembered that panel, and searched through my parts stash to find it.

    The clock was broke (think I said that), so I wasn't especially heart broken about cutting on the panel, OK, it did cross my mind, so don't cut up good ones!! but, anyway...past my moral issues.
    With the parts of the clock removed, I put the A/F gauge on the panel, and marked the outline. cut out the bits that weren't needed, and used the dremmel to smooth it out til the gauge fit nicely.
    Here's a bit of my work after test-fitting.

    Click image for larger version. 

Name:	AFGauge.jpg 
Views:	20 
Size:	242.3 KB 
ID:	45932

    needs a LOT of cleaning and a bit of paint, but should look decent enough. You can see some gap at the bottom of the gauge, where the 3 buttons were, but I think it looks OK.
    I also now have a shiny new switch I can assign to something cool (probably my water to air intercooler pump)
    Eric C
    SVOCA Webmaster

  5. #5
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    reserved-4
    Eric C
    SVOCA Webmaster

  6. #6
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    Reserved 5
    Eric C
    SVOCA Webmaster

  7. #7
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,693
    SVO's: 86-1C & 86-1E
    Updated
    Eric C
    SVOCA Webmaster

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •