Results 1 to 13 of 13

Thread: blue smoke idle

  
  1. #1
    6 PSI Boost
    Join Date
    May 2019
    Location
    Jeffersonville, IN
    Posts
    18

    blue smoke idle

    I recently have an issue with my 84 while idling it wants to put out blue smoke which I know is usually oil. It has 80k original miles. I removed the intake tube going to the turbo and it was dry and the outlet going to the TB was dry. This just started all the sudden. I recently did a timing belt, water pump, and thermostat. I did a dry compression test and all cylinders were 152.

    After doing the timing belt and all that I went on a test drive and the car kinda back fired.. then all this started. I pulled the plugs and they don't look bad either but I just replaced them last week. Any ideas ?????
    84' SVO

  2. #2
    4 PSI Boost FLhotrod's Avatar
    Join Date
    Sep 2003
    Location
    Pembroke Pines FL
    Posts
    6
    SVO's: 86 9L SVO
    My hazard guess would be valve stem seals. Every 2.3 I have own (85 TB/86 SVO) around the 50K mark, I had to change the valve stem seal because of blue smoke at idle and between shifts. The back fire may have dislodge a valve stem seal and since you indicate 80k original miles this is where I would start looking.

    I believe newer seals are made with different material and last longer.

    hth

  3. #3
    Pimpin Pumpkin Carver Laredo's Avatar
    Join Date
    Aug 2006
    Location
    Stillwater, MN
    Posts
    1,190
    SVO's: 86 2R
    Quote Originally Posted by FLhotrod View Post
    My hazard guess would be valve stem seals. Every 2.3 I have own (85 TB/86 SVO) around the 50K mark, I had to change the valve stem seal because of blue smoke at idle and between shifts. The back fire may have dislodge a valve stem seal and since you indicate 80k original miles this is where I would start looking.

    I believe newer seals are made with different material and last longer.

    hth
    ^^ Yes! The valve stem seals get so hard and brittle when they get old and heat-cycled that they will literally crumble to dust.
    "If there's no plan, what can go wrong...?"

  4. #4
    6 PSI Boost
    Join Date
    May 2019
    Location
    Jeffersonville, IN
    Posts
    18
    Thanks for the help.. I ordered new seals. hopefully thatll fix her..
    84' SVO

  5. #5
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,914
    SVO's: 86-1C & 86-1E
    you know what you're getting into to change those ?

    Also, no one here mentioned, but the later 87-88 turbo-coupe seals are a better design (same engine)
    hopefully where ever you ordered these from, knew this and substituted...
    Eric C
    SVOCA Webmaster

  6. #6
    6 PSI Boost
    Join Date
    May 2019
    Location
    Jeffersonville, IN
    Posts
    18
    Eric... yes sir I ordered the turbo coupe seals.
    84' SVO

  7. #7
    14 PSI Boost Kens svo's Avatar
    Join Date
    Aug 2015
    Location
    Stony Creek, New York
    Posts
    88
    SVO's: 84 1C, 86 2A, 16 GT
    I am going through the same thing, ordered the seals for the turbo coupe (Viton metal clad) from Rock Auto. Attempted to install them tonight, but failed. The bottom boot that goes over the valve guide will not fit. Anybody else have this problem, local part stores are saying- valve seals are not available. Help, engine is apart and driving weather is here. Thanks

  8. #8
    Administrator SVOeric's Avatar
    Join Date
    Mar 2002
    Location
    Richmond, KY
    Posts
    12,914
    SVO's: 86-1C & 86-1E
    Never seen that problem, and I've done several sets of those over the years.
    Do you have the head off ? or doing in-place ?

    Are you sure the old seal has been completely removed ?
    Read the instructions closely, there is a difference between intake and exhaust.
    Eric C
    SVOCA Webmaster

  9. #9
    OVER-BOOST!! svono50's Avatar
    Join Date
    Apr 2002
    Location
    Streamwood, IL
    Posts
    4,009
    SVO's: 86 1C
    To add to Eric's questions, any pics of what you have??
    Ted
    86 SVO Mustang
    17 Cooper S Clubman ALL4

  10. #10
    14 PSI Boost Kens svo's Avatar
    Join Date
    Aug 2015
    Location
    Stony Creek, New York
    Posts
    88
    SVO's: 84 1C, 86 2A, 16 GT
    Doing it in chassis, yes, I have intake and exhaust. The old one came off in one piece complete. Attempting to add pictures now.

  11. #11
    14 PSI Boost Kens svo's Avatar
    Join Date
    Aug 2015
    Location
    Stony Creek, New York
    Posts
    88
    SVO's: 84 1C, 86 2A, 16 GT
    Here are the pictures
    Attached Thumbnails Attached Thumbnails E98C24E1-AF37-4C71-A246-59E1EF43212A.jpeg   CD63995E-CF17-4E83-AEEB-DD3A25947665.jpeg  

  12. #12
    14 PSI Boost Kens svo's Avatar
    Join Date
    Aug 2015
    Location
    Stony Creek, New York
    Posts
    88
    SVO's: 84 1C, 86 2A, 16 GT
    After some long research, the seals I ordered are for a HSC engine. That was used in the Tempo/Topaz 2.3 engines. But listed under the turbo coupe listings on Rock Auto. There are many others on the site which ones are recommended? I rather not make the same mistake again. Thanks

  13. #13
    6 PSI Boost
    Join Date
    May 2019
    Location
    Jeffersonville, IN
    Posts
    18
    I just replaced the valve stem seals in my 84. I used the seals for a 87 turbo coupe and they fit perfectly. Here is the seals I ordered off rock auto. It fixed my blue smoke issue... hope it helps you out..
    FEL-PRO SS72683 {#E7ZZ6571A, E7ZZ6571B, F3ZZ6571A} Set; Includes Stem Seals
    84' SVO

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •