Announcement

Collapse
No announcement yet.

clutch is squeaky on return

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • clutch is squeaky on return

    I have a 1984 mustang SVO and whenever i let off of the clutch (on the return) it squeaks does anyone know how to fix this i tried greasing near the clutch peddle but that did not help thanks in advance

  • #2
    You may try some lube at the point the cable connects to the clutch quadrant. I assume the noise is coming from under the dash and not from the linkage under the car?

    Is it stock configuration or aftermarket adjustable?
    Mike S

    '86 SVO 9L Leather
    '86 SVO 9L Road Warrior
    '96 300ZXTT

    Comment


    • #3
      everything is stock and it only has 30k miles it could be the linkage if its not to much of a hastle for you could you send some pics of the parts i would need to lube?

      Comment


      • #4
        Take a look at post #6 here:

        http://www.svoca.com/forum/showthrea...lutch+quadrant
        Mike S

        '86 SVO 9L Leather
        '86 SVO 9L Road Warrior
        '96 300ZXTT

        Comment


        • #5
          There are only (2) dry plastic bearings that the clutch shaft rides on, so you only have (2) spots to worry about. Even though you have low miles, the plastic sleeve bearings are 30+ years old now. Those plastic sleeve bearings look like this for reference:

          2MTR1_AS01.jpg

          My factory units were a light cream color, but I have seen them black as well.
          Ted
          86 SVO Mustang
          17 Cooper S Clubman ALL4

          Comment

          Working...
          X