Page 2 of 2 FirstFirst 12
Results 16 to 22 of 22
  1. #16
    OVER-BOOST!! gbeaird's Avatar
    Join Date
    Apr 2002
    Location
    Pearland, Texas
    Posts
    2,338
    SVO's: '86 2R
    The fitting on the turbo itself IS pipe thread. A pipe to flare adapter screws into that port, and the end of the cooling line that screws into the adapter is 1/2" flare, IIRC.
    Gene Beaird,
    86 2R SVO, G Stock,
    Pearland, Texas

  2. #17
    14 PSI Boost
    Join Date
    Oct 2005
    Location
    Ooltewah, TN
    Posts
    86
    SVO's: 1985 1/2 9L
    Quote Originally Posted by gbeaird View Post
    The fitting on the turbo itself IS pipe thread. A pipe to flare adapter screws into that port, and the end of the cooling line that screws into the adapter is 1/2" flare, IIRC.
    Yeah, that is what I have seen too. Neither are metric however, and the link that the OP gives for that water line says that it has M16x1.5 fittings, and the picture shows a straight thread fitting with a copper compression washer. So, I am dubious that this particular water line will work with our OEM turbos. That is not to say that there aren't T3 turbos out there that have water ports that are something other than an American NPT, I'm sure there are, but I'm pretty sure our OEM turbos are not metric.

  3. #18
    17 PSI Boost RodneyH's Avatar
    Join Date
    Aug 2002
    Location
    Allentown, Pa
    Posts
    241
    SVO's: 84 - 2A
    Quote Originally Posted by GAboySVO View Post
    Just an FYI, my brother has worked with a tube company in FL to make duplicates of the Forced Ford Stainless Steel replacements. He will be posting info and part numbers soon.
    That's great news if it works out.
    84 SVO 2A
    83 TBird TC & 5.0
    and a few other Fords

  4. #19
    14 PSI Boost
    Join Date
    Sep 2009
    Location
    Surrey, BC
    Posts
    58
    Hi guys,

    I too am having to fix / replace this line on my 85.5. I just replaced the lower (supply?) coolant line going from the block to the turbo and then realized there is a small leak occurring at the return(?) line flare nut end. I see someone previously had this problem and used Teflon tape on the flare nut threads, but I suspect the flared portion of the line is split. I have a used line being sent to me, which I'll inspect and hopefully be able to use when it arrives. Otherwise I'll be looking to see if a local shop can fabricate a hard line or possibly go the s/s braided AN fitting route as previously mentioned.... OP, let me know what you ended up going with and if it worked well for your application...thanks!Click image for larger version. 

Name:	20210323_092403.jpg 
Views:	5 
Size:	190.2 KB 
ID:	47539
    85.5 1E in the house.

  5. #20
    14 PSI Boost
    Join Date
    Sep 2009
    Location
    Surrey, BC
    Posts
    58
    Here's 1 option that I ended up making. Very much overkill and expensive, but it will work. I may try bending and flaring some copper tube today as well, as another option..more original looking anyways...Click image for larger version. 

Name:	20210415_135250.jpg 
Views:	2 
Size:	228.2 KB 
ID:	47575
    85.5 1E in the house.

  6. #21
    OVER-BOOST!! svono50's Avatar
    Join Date
    Apr 2002
    Location
    Streamwood, IL
    Posts
    4,274
    SVO's: 86 1C
    Nice piece of work there and will certainly do the trick. I think Gene is going to get giddy with that one!!
    Ted
    86 SVO Mustang
    17 Cooper S Clubman ALL4

  7. #22
    14 PSI Boost
    Join Date
    Sep 2009
    Location
    Surrey, BC
    Posts
    58
    I tried my best to save the original line, using a new fitting and cleaning all the contact points, but the line ended up twisting and splitting
    My fancy braided line was next in line to be used and has worked well.
    Inverted flares and tube suck.
    JIC's are the way to go
    85.5 1E in the house.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •